0
Not a bug
AlexDr 4 months ago in Server Solutions / Linux Server • updated by Aleksandr Romanov (CTO) 2 months ago 20

В тестовом режиме все было ок. После перевода сервера (RPi debian) на коммерческую лицензию, не могу подключиться с панели (пока тестировал только на Android 6.0) к серверу.

Лог на сервере:

[18-06-2017 00:10:40.000]       INFO    IRIDIUMSERVER   Accept Client id - 0 1 ip:33968
[18-06-2017 00:10:40.000]       INFO    IRIDIUMSERVER   Welcome 4
[18-06-2017 00:10:40.000]       ERROR   IRIDIUMSERVER   Authorization error
[18-06-2017 00:10:40.000]       INFO    IRIDIUMSERVER   Offline(0) 1
[18-06-2017 00:10:40.000]       INFO    IRIDIUMSERVER   Release Client id - 1 ip:33968
[18-06-2017 00:10:41.000]       INFO    IRIDIUMSERVER   Accept Client id - 0 1 ip:33970
[18-06-2017 00:10:41.000]       INFO    IRIDIUMSERVER   Welcome 4
[18-06-2017 00:10:41.000]       ERROR   IRIDIUMSERVER   Authorization error
[18-06-2017 00:10:41.000]       INFO    IRIDIUMSERVER   Offline(0) 1
[18-06-2017 00:10:41.000]       INFO    IRIDIUMSERVER   Release Client id - 1 ip:3397

Пробовал под учеткой админа (создателя проекта) сначала. Потом под учеткой пользователя - выдал приглашение на доступ к проекту и т.д... в обоих случаях Authorization error

Читал раздел http://dev.iridiummobile.net/IRidium_for_iOS/ru#Commercial_Use - все делал как там описано.


Я что-то упустил?

Waiting for user's reply

Для начала, проверьте, что вы используете "свежие" версии сервера и клиента. На сервере при этом проект работает нормально (можно проверить по значениям фидбеков в веб интерфейсе)?

версии сервера и клиента самые последние. обновил на прошлой неделе сразу после выхода обновлений

фидбеки на сервере отображаются и реагируют на изменение состояний оборудования, но не отображаются в интерфейсе панели.


в статусе на сервере:

License info:

Type: Comercial use
Tags: 250
Panels: 5


Здравствуйте!


Проверьте пожалуйста не задавали ли вы пароль в настройках серверного проекта.



Не помню чтоб я его устанавливал в серверном проекте, но кажется он установлен - есть несколько символов за звездочками. Вместе с этим значения полей Login и System ID не были заданы.  
Кстати, значения полей Password панельных проектов не скрываются звездочками:

Я перезалил в облако панельный и серверный проекты с пустыми полями login и password и SystemID. 

Ситуацию это не поменяло. Так же ошибка авторизации в логах на сервере.

После того, как вы перезалили проекты на облако, вы обновили их на панели и сервере? Вы говорили что в тестовом режиме все было нормально. Если сейчас попробовать ваши проекты залить на сервер и панель в тестовом режиме?

Обновил и сервер и панель.

Сейчас я не рядом с сервером. Не находясь в одной сети с сервером залить проект через Transfer как то можно?

К сожалению, нет. Трансфер работает только в локальной сети. Но если вы находитесь в пределах одной локальной сети, но в разных подсетях, то Трансфер должен найти сервер.

Попробовал залить в тестовом режиме - все отлично работает.

Можете прислать ваши проекты? Только пожалуйста, отправьте их на нашу почту support@iridiummobile.ru

пришлю, но теперь уже после 04.07.17

Уехал в отпуск...

перед отправкой проекта обновил сервер и клиент до последней версии, которую недавно выложили на сайте:

Все повторилось - на коммерческой лицензии в логе сервера ошибка аутентификации клиента.

Но я смог найти зависимость, в каком случае ошибка пропадала. Оказалось, что надо было чтоб название серверного проекта начиналось с буквы!

А у нас проекты по стандарту именуются "год-номер_проекта заказчик"


К сожалению, повторить не удалось. Все таки пришлите ваш проект, на котором это наблюдается и опишите все ваши действия.

Здравствуйте, Ваша проблема еще не решена?

Добрый день.


Проблема разрешилась, я об этом написал чуть выше: 

я смог найти зависимость, в каком случае ошибка пропадала. Оказалось, что надо было чтоб название серверного проекта начиналось с буквы!
А у нас проекты по стандарту именуются "год-номер_проекта заказчик"

Дмитрий написал, что у нас не повторилось...
Хорошо, мы перепроверим это еще раз, и если не повторится закроем тикет. Но если где-то отловите подобное - напишите пожалуйста.

Хорошо, скоро смогу проверить на другом проекте.

Здравствуйте!


К сожалению, указанная вами ошибка не повторяется. Можете написать точное название вашего файла, на котором вы наблюдаете указанную вами проблему? Свой файл я назвал "1_2_Server", но при загрузке его на сервер с комерческой лицензией, указанную проблему не наблюдаю.

Также уточните, эта проблема повторяется только на raspberry или на windows сервере тоже ?

Перепроверил с проектом, в котором этот глюк проявился. Он не воспроизводится. Имя проекта было в виде "016-04 Project owner"

Когда переименовывал проект называл его "ok 016-04 Project owner" - после этого все заработало. В тот же день вернул название на первоначальное и глюк повторился.


Сейчас все работает с первоначальным названием. Проверил с двумя панельными проектами (планшетный и телефонный интерфейсы), работающими с этим сервером.


Каких-то принципиальных изменений в серверном и панельных проектах не делал. Само починилось?))

Not a bug

Здравствуйте!


К сожалению, сейчас уже трудно сказать в чем именно была проблема. Возможно это была какая-то временная неполадка. Если сейчас проблема не повторяется, то мы закрываем этот тикет. Но если проблема снова повторится, то обязательно сообщите нам об этом.