Under review

KNX IR module not working properly after edit

Govinda Raja 6 months ago • updated by Slava Zhuravlev (expert) 5 months ago 29

KNX IR module works fine the first time. After Editing All the buttons send only one command.

I have 8 commands configured with TV module. Everything works fine the first time. Then when I add number keypad. All the 8 buttons on the TV module send the same command.

First I added the below commands. Everything worked well.

Then I added keypad as shown below

After adding keypad, keypad is working fine but all previous added commands shown is first picture send only one command. The command all buttons send is shown circled in red below.

Whichever button I press shown in image above, it sends only the command of the button circled in red.
Please fix this as soon as possible since it appears to be a major bug.

Project Name is YadamaResidence and I have shared the project with the support team.

Under review


thank you for the very detailed feedback. It allowed me to get fast into your problem.

I provided the information to our developers and we will try to fix it soon.

For now we couldn't repeat the problem. Did you try to add device with TV remote and keypad without editing?

The problem shows up when editing and adding keypad,

Everytime you say you could not repeat the problem. If you come on TeamViewer, I can clearly demonstrate the problem.

I am not even able to delete the defective module, since I get the message my config is being used by another user

Did you update your app today? We have released new version it may help you.

If it didn't help you then we are open to the teamviewer session. Send ID and pass in the private topic that you created: http://support.iridiummobile.net/topics/13731-urgent-help-required/#comment-82151

I have updated the app. Please come on TeamViewer

Copied it.
Deleted the message in security purpose. This is not private topic.

We will connect in few mins.

We will continue work tomorrow from morning as my collegue said to you. Sorry that we couldn't help you today.

Now I hope you are convinced that there is a problem after i demonstrated the issue.

Yes, the problem is totally clear for us now, thank you. KNX programmer is working on it. I will inform you about any results.

We have found the reason of the bug. If you add a remote for a device, set it up, restart your project and set up some buttons again - the remote gets broken (totally the problem that you have). For now you need to just add remote and add keypad buttons without restarting your project.

In result, what you need to do by steps:

1) Add KNX IR module;

2) Add a subdevice (where you need to set up TV + Keypad);

3) Set up your TV Remote;

4) Set up your Keypad remote (do not restart your project - it will get broken again).

If you do everything by the steps everything will work fine. This is solution for you for now.

The other question that it is bug and we will fix it. But it will take time. 

If there is an edit to be done, what will happen if I mistyped something and have to edit later?

Is there a way to back up my project? A bug like this is ruining my work and I have to delete everything and start over again. Please suggest how I can save stable version of my project and later revert when something like this happens.

Do the bug ruin all your project not only the KNX IR module? In KNX IR module you can delete device and re-add it or just reinstall the KNX IR module (the solution is temporary). 
About project backup: you can test your project locally on a device. If something went wrong - delete it locally and download working version from cloud. If project working correct - upload it on cloud. So main thing is to upload project to cloud only if it tested and working properly.

You can save different versions of project locally on each device but it will be shared only after upload on cloud.

I hope this will help you for now.

KNX IR can be added with multiple modules. But cannot delete 1 module. If the KNX IR is deleted all IR modules are deleted. This is extremely painful

Today update will be available so you can delete devices separately without deleting the whole module. The version is on tests right now.

The new version is out. Restart your project and update KNX IR module. So you can delete devices separately (the delete button in the bottom of a device section).

Sure, I cannot do it today. I have an extremely important client presentation. Will do it later. 

I am unable to find the feature that you mentioned. I downloaded the latest file iridium_lite_setup_1.2.0 and installed. Cannot find option to delete.

I have shared a test project I created to test this. The project name is AV TEST. I have shared it with the support team.

I do not find the delete button mentioned in the previous post. On my IOS device I do not find the update either.

Slava, the kind of support I get from you is appalling to put it very politely. Do you check before posting? First you deny the existence of a problem. Then you mention that you cannot replicate the problem. After I prove the problem exists, you provide an unacceptable solution. Further the temporary solution mentioned in the post above is Vaporware. Extremely frustrating spending time troubleshooting with you when I should actually be working on my projects. I hope someone more responsible responds to the support queries.

Would you be so kind to post a screenshot of the delete button mentioned in the earlier post? I think you actually mean the delete button for the IR module, which will delete all the IR devices under that module. I feel you don't even understand the problem that you are trying to provide assistance.


In last version of KNX IR module (1.15.0) on actual app version there is "Delete" button for a remote so you dont have to delete whole module:

Thank you, I have tested the delete and it is working fine.

Has the big with regards to KNX module being broken on edition fixed yet?

Thank you for the test.

You will not have this issue if you don't reload project after adding each remote. Just add mulptile remotes, config them and reload after configuration.

Actually on last released version you shouldn't have the bug even with reloading each time because we tested new app (it was not released at the moment) and it worked fine without the bug. But, again, you don't have to reload project every time when you add remote: complete your configuration and reload project only after that. It will save your time and it should work more stable.

What if we edit the remote? Will it get broken?

On last version of app there shouldn't be problem with editing.

Please, let us know if the problem with editing still happens.

Have you tested or are you making me the guinea pig?

For sure we tested this.

Just did it by myself:

1) Created remote;

2) Made configuration for 4 buttons;

3) Reloaded project;

4) Made configuration for 1 more button.

My remote didn't get broke.

Also tried to create second remote after reload and made configuration for it. Worked fine. 

For the topic I need to know how it works for you. If it is fixed for you also I will close it.