Waiting for user's reply

Modbus error in newest version of i3PRO

oggi katic 2 years ago in Products / Modbus updated by Dmitry - support (expert) 2 years ago 6

I have a 2-3 installations right now where Modbus send commands dont work at all to control heating.. The same program/file i use on a old i3pro (1.0.8:10187) and it works without problem. When i use the same file in a version 1.1.9:12918 nothing happends at all. 

Nothing is changed in installations but i think that i3 pro has auto updatet and afterwards its not possible to control heating 

Waiting for user's reply


As far as I understand, you use i3Pro on iPad. Will your problem be repeated if you open your project in i3Pro on your computer? Can you send your project to our mail? support@iridiummobile.ru

Hi Dmitry, thats correct, I use i3Pro on Ipad's and the issue is only on the Ipad's. (From PC its working). I have sent you a project to view it..Any idea how to fix this bug? Best Regards


Please specify which version of i3Pro do you use on your computer? Also specify which license you are using for iPad's. Try installing the new version 1.2.0.

Try in the new version of the editor to create a project with a ModBus driver and load it onto the iPad. Will the project work which was create in the new version of the editor?

Hi again. The licens i test with is our developer licens. But the issue is the same at costumers with a basic Modbus licens + Costum Script. I have installed new Studio software > Loaded old project in this > saved as new project and tried to control Modbus. Nothing communication at all is working now. Now it writes that we have connection (Status = 1) but i cant control nothing now.. 

Why is all this happening now, when it worked so great for several years now? ? 

Hi again

Is there any solution on Modbus problems ? Nothing is working in new version of client for iPad & studio software


Sorry for delay with answer.

Now it writes that we have connection (Status = 1) but i cant control nothing now.. 

The value of the token Status = 1 indicates that Iridium was unable to connect to the equipment.

In order to see if Iridium has connected to the equipment, you need to watch the token OnLine. 

If the token OnLine  = 1, then Iridium has connected to the equipment. Please make sure that Iridium can connect to your equipment. You can try using a trial license for this