0
Answered

IR.EVENT_ITEM_RELEASE doesn't work any more after update 1.2.0

r riksma 2 years ago in Applications / i3 Pro • updated by Dmitry - support (expert) 2 years ago 8

After my client updated to iRidium 1.2.0 we were surprised to find some buttons not working correctly any more. After troubleshooting we found IR.EVENT_ITEM_RELEASE didn't trigger any more when you hold the button and then release it. I fixed it by adding IR.EVENT_ITEM_END_HOLD.


Was this change intentional? if so, why isn't it mentioned in the change log?

Waiting for user's reply

Hello.
This bug has been fixed in version 1.2.1.

Tatiana, this installer asked for 2 questions:
1) Was this changed intentional?
2) Why isn't mentioned in the change log?


i can't find these answers in your reply; but maybe i missed something.


Please, answer this installer in a neat way. I can't find anything about this fix in the change-log of 1.2.1


Thanks


Theo

Hello.
This is a bug. It has been fixed for macros. For events in scripts will be corrected in the next versions.

I can confirm 1.2.1 doesn't change anything for me because I do use scripts.

If you could let us know which version of iRidium will contain the fix that would be great!

Thank you for this detailed answer. You are on the right way.


But still no answers on the question from installer.

Hello, is there any plan when will be ready new version, where Release event we will get again? It's really big problem, because in AMX system is RELEASE event necessary to stop HOLD event - without RELEASE event is still firing HOLD event,  which leads for example to excessive amplification - and it is a very big problem, even to health of customer (damage hearing). We must now change AMX source code of stable application (removing HOLD events - and its functionality, which is not easy to exchange for any other solution) and it is not very easy to explain this situation to our customers - especially when we do not know, when repair will come. 

Thanks for quick response,

Roman

+1

Hello.
It will be fixed in version 1.2.2 on Monday (09 October)

Answered

Hello!


This issue has been fixed in version 1.2.2