0
Answered

Panasonic Bluy-ray

Jan Hein Liebregts 8 years ago in iRidium Script / AV and Driver scripts updated by Oksana (expert) 6 years ago 10
Hello,

I want to control my Panasonic Bluy-ray player.
I found the below info on the internet.
As it is possible to create an standard HTTP driver with POST, it should be possible.
Can somebody help me how to put this in?
Thanks.
Jan Hein


———————————————————————-

    [li]Host: An IP address specific to your device. I went with a static address 192.168.1.201[/li]
    [li]Port: 80[/li]
    [li]HTTP POST as follows:
    POST /WAN/dvdr/dvdr_ctrl.cgi? HTTP/1.1
    User-Agent: MEI-LAN-REMOTE-CALL
    Host: 192.168.1.105
    Content-Length: [length]

    cCMD_RC_[command].x=100&cCMD_RC_[command].y=100
    Where you would replace [command] and [length] with the following depending on the action needed:
    [/li]
Dear Jan,
please use this instruction for working with the HTTP driver: http://wiki2.iridiummobile.net/AV_%26_Custom_Systems:_Working_with_Equipment_via_HTTP


With best wishes,
Victoria Vaynert.
Hello Victoria,

I know this instructions.
In this instruction they talk about the Standard HTTP driver with the GET command.
I need the POST command. Is there an instruction how to use this in the driver?

Jan Hein
Hello Jan!


Please use this link with the instruction you require: [size=78%]http://wiki2.iridiummobile.net/AV_%26_Custom_Systems:_Control_via_HTTP#Syntax_of_HTTP_Commands


Have a good day,
Victoria Vaynert.
Hello Victoria,

Thanks for the info, but it is not working.
What have I done:
I have an programm called Wfetch to simulate the POST command.
When I push the GO button my Blu-ray player is responding to the command.
See the first image attachment.

When I then put the POST command in an Standard HTTP driver with the POST command it isn't working.
I also put the IP and Port number in the driver properties.
Also used the User Agent command in the properties, but this did not help.
See the second image attachment.

Is there something wrong in what I'm doing?
Can you help.

——————————
Extra info
——————————

This is the HTTP communication detail of the sended data from the iridium client:

POST /WAN/dvdr/dvdr_ctrl.cgi? HTTP/1.1
Host: 192.168.0.155
User-Agent: iRidium/2.0.7
Viewer-Only-Client: 1
Accept: */*
Connection: keep-alive.
Content-Type: application/x-www-form-urlencoded
Content-Length: 0

As you can see the content-lenght is zero. So I think the data is not send.

This is the HTTP communication detail of the Wfetch tool:

POST /WAN/dvdr/dvdr_ctrl.cgi? HTTP/1.1
Host: 192.168.0.155
Accept: */*
Content-Length:39

As you can see the conten-lenght is 39. This is working.

I hope this can help you.

thanks
Jan Hein


Wfetch.jpg
Wfetch.jpg_thumb
properties.jpg
properties.jpg_thumb
Hi,


Just a quick guess:

I think you need to put the data between quotes 'this is my postdata'


as you can see when you put it between quotes there are bytes added in the lower field of the custom data window.


Regards,


Benno
Hello Benno,

It looks already an little bit better now, but still no response.
I have this as the HTTP communication detail:

POST /WAN/dvdr/dvdr_ctrl.cgi? HTTP/1.1
Host: 192.168.0.155
User-Agent: iRidium/2.0.7
Viewer-Only-Client: 1
Accept: */*
Connection: keep-alive.
Content-Type: application/x-www-form-urlencoded
Content-Length: 39

cCMD_RC_OP_CL.x=100&cCMD_RC_OP_CL.y=100

The content-length is OK now. But when you look in the working version, there is not the last line with the command in it. But is working.

POST /WAN/dvdr/dvdr_ctrl.cgi? HTTP/1.1
Host: 192.168.0.155
Accept: */*
Content-Length:39

So what could be the problem?

Extra info
———————————————–
Could it be that the command (cCMD_RC_OP_CL.x=100&cCMD_RC_OP_CL.y=100) is in the header?
It should be in the body.

Thanks
Jan Hein
Jan,
you should put everything of the Data field in single quotes. You have to change the user agent in the driver settings and put it in quotes. The other data leave without any change. Please use a project in the attachment. It was created for your device.
POSTproj.irpz
Jan,
you are welcome!

Feel free to contact us,
Victoria Vaynert.