+3
Waiting for user's reply

cannot select Dynamic Images from the project gallery

r riksma 5 years ago in iRidium Script / Interface scripts updated 5 years ago 9
Please see attached project. (note: camera URI is replaced with a dummy and should of course be changed before testing)
creating a Dynamic Image in the Project Gallery and assigning it to an item by script does not work.
Dragging and dropping the Dynamic Image on an existing item does work.
Referencing the URI directly also works.

While this is not a very big problem, this was kind of unexpected and caused me to think there was something wrong with the URI i was using.
Please fix if possible or maybe update documentation with this info?
cameras.irpz
Client

Answer

Answer
Planned
Dear Riksma,

At the moment you can assign only MJPG stream using the script (but not H.264).
We know about this problem, it will be fixed in the next versions.

Sincerely yours,

Olga Ermakova
iRidium mobile Team
Answer
Planned
Dear Riksma,

At the moment you can assign only MJPG stream using the script (but not H.264).
We know about this problem, it will be fixed in the next versions.

Sincerely yours,

Olga Ermakova
iRidium mobile Team
Right now the stream is working, but it takes a while to start. i suspect this is mainly because of the default probe size. Is there a way to set this parameter by script?
It would be best if other settings like Demuxer could also be set.

If it is not possible right now, do you have a timeframe for the implementation?
Hello

It is not possible to change a camera settings true the script, but u can try to set up camera in Dynamic Images tab, and then link this cam to item by name like
IR.GetItem("Page 1").GetItem("Item 1").Image = "Camera";
we are not sure about time when we add this ability in iRidium
Hello Ekaterina,

This would be a good solution if it would be possible to set up H264 streams this way. Julia has said in this topic this doesn't work right now but a fix is planned. I don't think it is very important that we are able to change the settings by script, but i do think it is very important that we are able to change the settings for h.264 streams at all.
If this can't be done the camera has to work with default settings or it doesn't work at all.
Please consider making one of the fixes a priority.
But u are able to change the settings at all, in gallery. You can set up the probe size and choose a transport in Gallery. It is not possible in script only. Yes we plan to add this possibility.
the settings can be changed in the gallery, but the image from the gallery cannot be assigned to an item created by a script. I create every object (pages,items,popups) by script. that's why this is a problem for me. If I would be able to assign the h.264 image from the gallery to an object created by script it would be fine but right now this feature is severely limited for me.