Can't get device HWID - Windows 8.1

Maciej Walentowski 7 years ago in i2 Control V2.2 updated by Aleksandr Romanov (CTO) 7 years ago 5

i2 Control 2.2.3 working correctly on PC with Windows 8.1 Bing without internet connection. Last time stop working and have information about "no licence found" and after open system menu and info have: "HWID Can't get device HWID" Where I should looking for that problem?

Iridium transfer doesn't see that panel.

Waiting for user's reply


Try to log in as an administrator. Or run i2control with administrator rights.

It was the first thing I checked, but it didn't solve the problem. I have administrator rights and run i2control with administrator rights.

After that, the application stopped working? What led to this? Is the system visible on the network? Have you tried completely to remove i2control and install it again?

Problem solved. I found it after reinstall Windows. 

Comp is PC on stick - Lenovo ideacentre Stick 300, I use it with USB lan adapter and switch off WiFi card in control panel -> network connections. When WiFi card is off, then i2control can't get device HWID, after switching WiFi card on, i2control work correctly.