0
Under review

HTTP project upload (download) not working

Ron Verstappen 4 years ago in i2 Control V2.2 updated by Dmitry - support (expert) 4 years ago 5

Hi,


I set up downloadable projects based on the information provided in the wiki:

http://wiki2.iridiummobile.net/Updating_Projects_via_the_Internet


When I click on any of my projects, including the test project in the example, i2 Control 2.2 tries to "upload" the project after asking "Do you want to update the design?" but then just sits there forever with the message: "The project is uploading. Please wait." My links to the projects are here (The last link is a copy of your example irpz file):

https://www.googledrive.com/host/0BzoEPlryM3jtYXVBVzY1Ykl0eGc/links.html


This happens on multiple devices running Android (no access to iOS devices):

Android 6.0.1 (Nexus 5X)

Android 4.4.4 (Moto X)


Any help would be appreciated.

Ron

Ron, did you read the section with the Google Drive? Because i don't see the correct URL in your link (the https://drive.google.com/uc?export=view&id=[FILE ID]


Please let me know.


Thanks


Theo


Thanks for your response, Theo.


Although my URL was not exactly the same they all still point to valid files. I've now added links to the exact paths per the wiki but I still get the same problem, which isn't really surprising, I suppose, since all of the paths actually download the files in the same way when just using the link without the iridium://webupdate? prefix.


Hi

I have only ever used this on iOS and it works fine (just checked)


Then I tried it on Android with the same project and it does not download.


A bug for Andriod? I am using a Samsung Galaxy S5 (android 5.0.1) and tried also on Samsung Galaxy S6 (android 5.1.1)


QRCode works fine with Android




Jackie, thanks for helping to verify the pproblem: a bug in the Android version. I'll try QRCode.

Under review

Or you can install version 2.2.3 from our site. In version 2.2.3 remote download project on Android works.