Searching answer

teamviewer and i3pro

Paul van Boven 7 years ago updated by Vladimir Ovchinnikov (expert) 6 years ago 48


I have got the following issue.

When I have a windows panel and a fullscreen project, most of the time I can't see the project (blackscreen or the loadingscreen) when I logged in to with teamviewer. Sometimes after switching the windows by start menu, back to i3pro a number of times I will get the image right. And I can see the project.

my regards'

Paul van Boven


Perhaps this is due to the fact that TeamViewer compresses images during the transfer or it is due to incorrect drivers on your video card.
With technical support we never faced such a problem.

Same problem over here, for teamviewer and also for VNC, tested from and to several computers... so pls look into this!

Without using these products, everything works well? I think that this is not really a question for us, but rather for developers of systems for remote management.

But the strange thing is that when you start I3pro you can see that it does something with the graphic driver when is start on fullscreen. I use more fullscreen applications, but i3pro is the only one with this strangs behaviour.

It does something with the grapic driver. I think it's not the problem of the developers of the remote management systems.

I thing I3pro tricks the system.

Hi Paul,

See the same happening over here...

So i also think the cause is iridium, not the remote managment systems. Also because it happends in Teamviewer AND VNC viewer...


yes. connection to a windows machine running i3pro client via remote desktop doesn't work well.


Please fix this issue, it’s very annoying when giving support.

Under review

Who can provide access to such a project? We regularly use remote access systems in technical support, but we have never faced such problems.

For example. Make a Windows7 iRidium Client Application and run it. Also include big Trendcharts on other pages. Then, connect to the computer via another over Windows Remote Desktop RDP connection.

Can you provide access to such an installation?

I have made a video of the issue. I've used TeamViewer, but with VNC it is exactly the same.

Resolution of the panel and the iRidium project is 1920x1080.

Video card is onboard, as with many touchscreens: Intel HD Graphics



So it happens ONLY in the work of a full screen. In this mode, some videocards (like Intel HD 5000/6000 series) switch the display to exclusive mode. We can not fix this, because it depends on the drivers for the specific hardware.

Yes, but all panels that are installed at our clients run in full screen mode.

This was never an issue before the i3 Pro / i3 Lite merge.

"i3 Pro / i3 Lite merge" - what you mean? We have not changed the rendering system since the launch of the product (it is absolutely the same for lite and pro). Try full screen mode on a PC with a normal graphics card, it will not work either?

The emulator recently changed (if I recall correctly it is since the i3 Lite and Pro editor became one):

Studio (

  • One editor for Pro and Lite

The emulator then became a lot faster (good thing), got a blue background and the project/system menu changed a lot.

Since this change the full screen issue started.

Searching answer

Well, we'll check the version from 1.1.* branch and current ... If it worked before, and then it stopped, then it's a bug... But as far as I know, it never worked on some video cards ....

I've installed the 1.1.9 Client on the 21 inch touchpanel I have here and you are right.. problem also exists on this version. You can stop the search, sorry.


I have seen this same issue if I have another monitor connected to the tablet. To solve the issue do not connect another monitor and add a small flashing indicator on all pages. 

I don't understand why adding a flashing indicator would fix this issue. 

If I connect with TeamViewer while iRidium is running fullscreen, then press a button on the touchscreen to go to another page or show a popup, isn't that also causing a 'change'? Because in my case the remote connection is not updated when I do this.

When I had this issue as shown in the video, it was due to connecting to a second monitor. I also had the issue where if I tried to use VNC during full screen, the image went back. I found that adding a flashing indicator solved the problem and have been doing this for several months now for all of my projects and no longer have the issue.   

Ahh yes, In the past I’ve also noticed that with VNC the screen stays black, I’ll try adding a blinker for the VNC problem. I guess a blinker won’t solve the teamviewer issues.

This touchscreen doesn’t have a second monitor connected, I also checked if there were any ‘phantom’ monitors in Windows, but there were none.

Experienced the same issues both with teamviewer and VNC. If I have time I will try to make a test setup for you to see.

By the way also i3 Studio doesn’t like teamviewer (v9) very much. When I support a colleague with a Studio problem using teamviewer sometimes the Studio window becomes unusable/blank and it won’t return until you disconnect the teamviewer session.


I figured the issue is due to no changes. I fixed this same issue with VNC by placing a flashing 1 second dim LED on each screen.


We start research your task. It works via teamviewer in our office, so i need addition info. Can you send me project that has problem with teamviewer, write PC configuration and internet channel width

If you supply an e-mail address I could send you the project.

PC config (tested here at the office with 2 laptops):

Windows 10 (x64)

Core i7 2.7Ghz


Intel HD Graphics 530 & AMD FirePro W5130M


100 Mbit Up

100 Mbit Down



Make a copy of the project and in Project Properties set the Target Device:

iPad 1, 2 (1024x768)

Note: Landscape Width and Landscape Height does not exceed the real resolution on the computer to which you want to connect remotely. The screen resolution on the computer from which you will connect remotely, should not be less than that specified in the project.

Run the project on a computer running Windows and connect to this computer via RDP. Expand the project in full screen. The project looks like a black window?

Optional: on this computer install Radmin and try to connect via Radmin. Expand the project in full screen. The project looks like a black window?

Same thing try to do it through Teamviewer.


I have the same problem.

When I connect a touchpanel (Win 10) with Teamviewer (12 or 13) I have almost every time a black screen.

Clicking, restart iRidium, etc. etc. won't works.

In Windows I don't have a problem with black screens or something. It's exclusive for the the iRidium application.

Please, fix it soon.

Best wishes,

Harm Lamers

Please specify: what resolution is used in Project Properties (Landscape Width and Landscape Height)? What is the screen resolution on the device, which is connected via Teamviewer? What screen resolution is used on the device that is connected?

The problem is with different resolutions. I always make the project in the resolution of the screen. For example if the screen resolution is 1024x768, The project resolution will be 1024x768. But I got the same problem with for example 1920x1080.

The problem is the screen resolution. Color depth and the manufacturer/model of the videocard do not affect the appearance blackscreen in a remote connection. If you set a project resolution of 1920*1080, you do not need it to start on the screen with a lower resolution (if you have a screen 1600*900 - in project, specify same). Moreover, it is not necessary to connect remotely from the device on which the resolution even less (e.g. 1280*720). Under these conditions, in most cases, the application window will be unreadable, even through teamviewer, even through RDP.

I have a project with a 1920x1080 touchscreen, which runs an iRidium file which is 1920x1080 and I connect from my laptop which has a 1920x1080 screen via teamviewer. Also a problem, so it’s not a resolution related problem.

If you connect via RDP or Radmin - the problem remains? TeamViewer uses its own proprietary protocol. It is not documented in transfer of the image. We got the normal work of the presented project in full screen when connecting via RDP and connect via Radmin. You need to match the project resolution and screen resolution on computers.


Same problem here.

Project resolution: 1920x1080

Remote screen resolution: 1920x1080

Client pc resolution: 1920x1080

Remote program: TeamViewer and tightVNC

In "full screen" mode i have a freeze screen only on i3Pro, more i not set "always top" but i3Pro set focus on it and i can't show any other application (i can't see task manager....!)

More I suggest to create a shortcut for switch between full screen mode and window mode!


What is Render in the panel project (OGL, DX11, etc.)?


Render is set as OGL

I have tried all the different settings, none of them work.

Make sure that the device you connect supports OpenGL 3.0 and correctly working with him (do a load test on your hardware). Westmere Microarchitecture (Socket 1156) will not work, because it only supports OpenGL 2.1.

Hello Vladimir,

I not understand...if my devices (all devices have this problem) not support OGL3.0, i3Pro can run with render setted as OGL?


If your devices do not support OGL 3.0, then the rendering in i3Pro will not work. If there is DX11, try temporarily using DX11 instead of OGL. Probably the problem is in fullscreen via VNC will not appear. Note: DX11 is beta, use it with caution.

ok, but when I use i3Pro in local (on touch-screen) it work fine, fullscreen or not.

I have problem only when i try use 13Pro in remote (connected with teamviewer or vnc on touch-screen). If the problem is the support OGL, is possible that i not have problem in local?


For Intel HD very important a stable framerate, especially if the screen resolution changes dynamically. Locally no problems. When switch i3Pro in full screen, the resolution changes to what is specified in the project settings. If it is greater than actual, the VNC session will see only "black screen". In some cases you can work around this, but it's not a problem of the render. This is a problem of the device.

As noted before, resolution of the project is exactly the same as the native resolution of the screen and the resolution windows is set to.

The strange thing is, when i3 Pro is running in Full screen and I open a TeamViewer session, I see the Windows desktop (while i3 is shown on the actual touchscreen). With TeamViewer I cannot click on anything on the desktop, when I click on something I actually click in the i3 Pro application.

Teamviewer I can not comment, because it uses a proprietary protocol and there are no publicly available documentation about how it transmits the image.

About VNC more clearly.
VNC viewer can not in the active session to change screen resolution dynamically. In some viewer (UltraVNC, RealVNC) there is Auto Scaling, but in this case it is useless, because it is triggered only when creating a VNC session.

You can do so.
1) connect via VNC,
2) start project,
3) transform the project in fullscreen - get the "black screen",
4) in the VNC session, send keystrokes "Ctrl+Esc" (do it like UltraVNC or TightVNC),
5) disconnect (just close the VNC window viewer),
6) again connect and get a rendered picture running application, in fullscreen (it is possible to work normally - until the next disconnect).

Repeat the above steps after the disconnect can be many times. If the server will use TightVNC, it is recommended to install the DFMirage Driver. This will improve the capture of the pixel data more efficiently and will help to better detect the screen refresh.

With Teamviewer such tricks don't work.


Yesterday I used Anydesk on a PC running both full screen and windows mode without any issue. When I change modes, I do have to restart Anydesk to get it to resize properly. The same is true with VNC applications. I also have a 1 second flashing button on my i3Pro application. Without the flashing button the screen will not refresh. Try a flashing button and see if it works for you. I use TightVNC.

I use a small PC touch panel called a TCX9 and never have any issues with VNC.



I have had this problem previously.  Using teamviewer causes a black screen when any app is full screen.

This happens also in some version of vnc.

Something to do with the driver of teamviewer/vnc when an app is full screen ( I researched at the time of the problem, but do not remember the reference). 

The solution:  do not have iRidium app  full screen, but reduce by 1 pixel.  Eg instead of 1024 x 768  have iridium set to 1023 x 768.  The user will not notice and problem goes away.

Only for TeamViewer: try to install the monitor driver.

You can install the driver from TeamViewer:

We do not guarantee that this method will help you to get rid of the black screen in fullscreen via TeamViewer. On problems TeamViewer should contact its developers.