0
Answered

Read On Start

Harm Lamers 4 weeks ago • updated by Francesco Zangara 1 week ago 16

Hello,

Is it, and how, possible to easy change all Feedbacks from True to False in the server?

I want to disable it for all feedbacks.

Hope to hear from you soon.

Best wishes,

Harm

Under review

Hi

Please clarify:
1. Do you want to do this in the studio in the entire server project or while the project is running?
2. Which driver are you using? KNX? If this KNX, this property is copied from the ETS project.

Hello,

1: In the studio in the entire server project. 

2: KNX, Yes, and copied from the ETS project. But there I dont have an read on start option. 

There is no tool for batch processing of properties, it is necessary to set this property manually.

But why should you disable this feature? After all, then the server will not have actual data on the status of group addresses in the KNX - bus??

Because I have an project where 90% of the groupadresses don’t give an reply to the read-telegram from the server, the busload goes to 80% and strange things happens when restart the server. 

If the addresses do not respond, then why use the "Read on start" flag in the ETS ?? Remove it in the ETS and there will be no problems.

Sorry Aleksandr, but i not think that the parser on iRidium read the flag (on IPBaos, i don't know on Router / Interface).

Otherwise, why the parser create a feedback on object without "Write" flag? This object never change, this object is only for command.

More, if I set the "I" flag (Initial read) only on some object, the parser set the "Read on start" parameter on all feedback.

Hello, Francesco
With incorrect import, I recommend contacting technical support with the folowing information:

- version of the studio,

- including the ETS project and the project after import.


We are sure that the "Read on Start" status works correctly.

Hello Aleksandr,

Automaticaly the "Read by Init" is off at all my components. So I don't think thats the problem.

See image:

Start.jpg

But I use an Dummy for the iRidium Server. I always use the Enterprise server, not an Baos

Answered

I do not think I can help you without providing the project and the initial ETS. Contact technical support with this question.

Sorry for wait...

Try with this project.

Object 11 not have the "Read" and "Initial" flag, but iRidium import it with "Read on start" option.

IPBaos.knxproj


More...Still iRidium not import the description when import the Baos (sorry, i can't find my old thread for this issue).

Hello!


Object 11 not have the "Read" and "Initial" flag, but iRidium import it with "Read on start" option.

Thanks for the info. Yes, when importing your ETS project into the studio, for all feedbacks "Read on start" is set to "True". We will try to investigate this problem. And if this is possible, we will try to fix this problem.


More...Still iRidium not import the description when import the Baos (sorry, i can't find my old thread for this issue).

Sorry, but I do not see any descriptions in your project.


Please try adding descriptions to your project and try to import this project into the studio.


mmm...I have set the automatic description on ets parameter, so i can see it...


More..in Baos parameters are present the description fields. I thought the importer would take these values, sorry

But with Baos772 and 777 it work

mmm...I have set the automatic description on ets parameter, so i can see it...


Sorry, but I think this property is only used for showing in ETS. Ie this property is not saved in the project.


For example:

1) I switched on the same property for my project, which has BAOS 777 and BAOS 774


2) As we can see, ETS shows descriptions in the project

3) Then i imported this ETS project in iRidium. And we see that there are no descriptions for both devices. Instead, only names are used.

Iridium always uses descriptions as a name when you use import for ETS project, if they are specified in the ETS project.

But in this situation we see that names are used instead of descriptions. So there are no descriptions in the ETS project.

Hello Dmitry,

try with this... IPBaos.knxproj


777 and 774 have same configuration (parameter and group address), but when import on iridium i have different names for commands and feedbacks.


If I import as router, i have the names of group address

If I import the 777, i have the parameters "Description" as name

If I import the 774, i not have the name (the object description is automatical filled by ets)


So, Why 777 and 774 get different informations?

I tried with your project and saw the same situation that I wrote to you before. Descriptions are not imported for both devices because they are not in the ETS project. 


This is description for the BAOS 777 in ETS


But after import in iRidium we have the names for cannels, not description



If you mean that the names for BAOS 777 and BAOS 774 are imported differently, then I agree with you.



We know about this problem and we will try to fix it.

If you mean that the names for BAOS 777 and BAOS 774 are imported differently, then I agree with you.

Exactly.

777 import the string present into parameter "Description".


Is a good idea get this string if the importer can't find the description into the object. Or get the name of group address connected to object.