0
Not a bug

Web Interface рвет соединение после авторизации

Сергей Калентьев 4 years ago in Applications / Web-interface updated by Oksana (expert) 4 years ago 6

Ошибка повторяется на серверах windows xp 32 и raspbian. Сами сервера работают нормально, тестовые проекты отрабатываются нормально, но некорректно работает веб интерфейс. При заходе на сервер порт 8888 появляется форма авторизации

после ввода admin, 2007 браузер сообщает об ошибке


Проверял на Mozilla Firefox и Google Chrome.


содержимое папки /iridiumserver :

root@orangepi:/iridiumserver# ls -l
total 3816
-rwxrwxrwx  1 root root 3893248 Nov 17 13:18 iridium
-rw-rw-rw-  1 root root    1062 Mar  4 20:06 server.crt
-rw-rw-rw-  1 root root    1704 Mar  4 20:06 server.key
drwxrwxrwx 10 root root    4096 Mar  4 20:06 www

прикладываю вывод tcpdump -nnaX port 8888 на сервере

dump.txt

UPD: Проблема наблюдается только на одной машине, с других клиентов все открывается, значит проблема не в сервере а похоже в антивирусе или браузере на клиентской машине. Почемуто блокируется редирект при смене Location в ответе сервера.

Waiting for user's reply

Сергей, здравствуйте,


Если вы решили проблему, сможете поделиться решением? Возможно, что у других участников может появиться такая же проблема.

К сожалению саму проблему не решил... Пока вхожу на веб интерфейс через оперу с включенным режимом опера турбо. Без проксирования не работают ни Chrome, ни Opera, ни Internet Explorer. Что-то блокирует редирект. Стоит антивирус Kaspersky Internet Security 16.0.0.614, подозреваю что причина в нем, но временное отключение защиты не помогает. Операционка Windows7

Not a bug

Если вдруг решите, будем благодарны, если отпишитесь. А пока я тему закрываю.

+1

Добрый день, как выяснилось - проблема устраняется полной деинсталляцией антивируса Kaspersky Internet Security 16.0.0.614. Судя по всему, защита реализована на уровне драйвера сети, и отключением защиты в самой программе не исправляется.

Спасибо большое за информацию!