0
Не ошибка

iRidium native KNX driver (KNXnet/IP) doesn't work with ABB IPR/S 2.1 in Routing mode (nat=false)

Эмиль Боев 6 лет назад в Продукты / KNX обновлен Ekaterina (head of support) 6 лет назад 3
See the title of topic, please.
In tunneling mode (nat=true) it works fine.

Also, from the same pc laptop (through the same LAN/WAN equipments) another KNXnet/IP client works just fine in routing mode.

Suggestion: the problem in so called ActionMessageCode.
Some KNX Routers/Interfaces might need this parameter defined, some need this to be 0x29.
ActionMessageCode is the first byte after header in KNXnet/IP packet.
For example, for Action packet header if [0..5] 6 bytes length. And the seventh [6] byte will be exactly the ActionMessageCode.

If ActionMessageCode is not 0x29, it will be always equal to 0x11.



На рассмотрении
How many IP interfaces (network connections) you have on your PC?

Nat:true: KNX datagram has an IP address included; KNX answers to this IP
Nat:false: KNX answers to IP address from whom he received the datagram.
So problem may occurs if iRidium chooses default IP interface on your PC "incorrect" and sending the data to another IP interface. Another client may choose another IP interface. So please try to retain only one network connection (turn off any LAN or VPN connections) and try again.

Сервис поддержки клиентов работает на платформе UserEcho