0
Answered

BAOS internet connection

Dariusz 4 years ago in Products / KNX updated by михаил кручинин 4 years ago 23
Hello.
I have a problem with my smartphone communicating via 3G networks. As the gateway used BAOS 771. Communication via LAN is possible but as soon as I switch on the mobile network, unfortunately I'm not able to connect to my network KNX. I downloaded from your side turtorial where manually switch to a WiFi network to 3G network. Not really sure if I typed correctly access port. What do I enter? 3671?, 12004? or other ?. Does the project structure should be cloned as a gateway access gateway (screenshot?). I'll be grateful for the tip.Darek
Unfortunately BAOS's network card has TTL parameter only 16. This means that the packets from it can go throught 16 network nodes (switches, routers etc.) only.
Wikipedia_TTL
Via 3G it is always needed more TTL. For example LogicMachine has TTL=128 and it will work via port forwarding on 3G.
I've contacted with Wienzierl about this problem and they promised to increase TTL value in future BAOSes :(
To check TTL value you need to ping your IP in Windows CMD.

You may ping your router at home and then try to ping it's 80's port via 3G and check the difference. If it is less than 16 it will work.
For now the only way to solve this is make VPN connection (if your router can do it :) and there will be no such problem.
Евгений, what about BAOS 777? We have one of them in office and able to check, but I have to know where I can see this property.
May be the new model fixes this issue.
You have to ping it. In the cmd window you'll see TTL=xxx. Like on the picture below. It should be more than 16 (16 was for 771/772).
This is for 771


Thank you for your answer but I'm not able to connect with my KNX network via 3G. From what I noticed a local area network communication with the router KNX is the only port redirections 12004 this port on the router to router BAOS. PortCheckTool.com checking on whether the service is open to get a negative response. The only open port which is port 7000. Probably my ISP blocks ports to me. He says that I am fully open all ports! .So I wonder what am I doing wrong? Any ideas?
Dariusz
My router is a Netgear R7500 Nighthawk.
Your router supports VPN. Set it up. Then connect to this VPN from your mobile client with iRidium. After that launch iRidium and everything will work
Yes, my router has a VPN but Probably clients for android and ios. they are not supported? Router for 300USD !!. You can read on the screenshots. vpn.PNG
Answered
You have to activate the VPN in iOS and Android settings, they supports this service. But iRidium support is not able to support you in network administration. We didn't faced with your router and cannot help you with it (this services is outside the framework of technical support). Please contact to your Internet provider, they usually provide services for network setup.


If you plan to use KNX Router (KNXnet/IP) driver, you have to forward the port 3671 (UDP)
If you plan to use KNX IP BAOS (771/772) driver, you have to forward the port 12004 (TCP)
You have to set up VPN on Router and control panels to have a secured access.
Back to the topic. In order not to err in the settings. Is the router BAOS in the structure of the project is to be cloned, and one has the IP settings. local Wifi network and the other has external IP settings (IP fixed)? I would add that the internet is dynamic, it is 3g each have a dynamic IP connection.It will be easier as someone will post screenshots with the settings ..
I spent 60 hours trying to communicate with your application to my KNX network. My ISP is giving me two hours to remote settings 12004 routera.Port I redirected my router KNX BAOS771. The VPN connection despite the different settings not possible to configure. Any detailed information on your forum I can not get. I can only your application for 300USD throw in the trash. Local management of a KNX is cheaper records with Blue Home (5 euros) or ayControl. The only reason to purchase your application was just a possibility of remote management via the Internet. As a customer, and spending 60 hours on just getting a call from a client device would have me pay for it. The cost of two times greater than the cost of application. I doubt that I found such client. It is easier to use dedicated applications (GIRA, Busch Jaeger etc).
I do not know which side configuration problem but as a customer I would expect more support.
Regards D.
If you can't set up your router or don't know how network works it doesn't mean that the support is bad. Iridium support is the best one that I know. They really can't help you with your router.
Possibilities of iRidiummobile software are really great but it is so only if you know how to use them.
Couple of questions about your Internet service and your KNX installation:
1. Do you have static IP?
If so write it here without last (4th) part
2. Do you have any IP-KNX devices except BAOS?
My external IP address is static.
The internal WiFi network router address is static.
771 BAOS IP address is static.
When pings to the router KNX receives the TTL-16
Before buying BAOS 771 I had SIEMENS N146 router. unfortunately, but now it is broken. What is so hard about port forwarding on your router? I have no problems with the local communication! Where is it written that the support is bad? I have a problem and expect to resolve it. Step by step so far to no avail. Would you like to buy a router and get connected after 60 hours of configuration? Not unless you threw it in the trash. I'm simply tired of this.
If you could send me your ip and login/pass for the router and make it possible to configure it remotely I'll try to help you.
evg@elspace.spb.ru
Evgeny

As a happy owner of a VPN connection for a week. From two days trying to get my network of connecting to a KNX. Unfortunately to no avail. I did not make any changes to the network settings. My configuration is not based on any scripts only to changing the connection:

Internal_1 function ()
{
IR.GetDevice ("KNX ROUTER"). SetParameters ({Host, "1.1.1." port "12004" ConnectTime "120000" SendTime "0", PingTime "60000" Nat "0" });
}
External_1 function ()
{
IR.GetDevice ("KNX ROUTER"). SetParameters ({Host: "1.2.3.4" port "12004", ConnectTime: "120000", SendTime: "0", PingTime: "60000" Nat: "1" });
}
I spend the next ten hours to try to connect first. I do not know where is the problem? in your application? In my router ?, from my ISP? in my smartphone ?, provider of mobile Internet?, paid VPN service? I'm simply tired of this endless problem ...

Vpn connection with the log router VPN CONECT..PNG.

Nobody wants to help? I expected a greater commitment on our forum.

Dariusz, the support from iRidium is the best in the world.


But: there are many parameters that can be wrong in the total chain from your smartphone-3G-provider-network_provider-router-firewall-IT-network_in_your_home and many other things.


I have spent -just like you- days and days to access my home via my 3G connection (about 4 years ago when we started as Distributor for iRidium mobile in Belgium and The Netherlands). In that time, i used a D-Link router (850 or something like that). Tried everything, hours and hours. Believe me.

Then, at the end, i bought a new Asus RT-AC66U router. And 5 minutes later i could connect via 3G to my home.


What i want to say: EVERYTHING in the chain from your smartphone --> 3G network --> provider --> router --> firewall has to be 100% ok, and one stupid thing can interrupt your connection.


In my case, it was not the iRidium app. It was not the provider. It was not the 3G network. It was just my router. I exchanged my router and everything was ok since that time. I can control my complete house, including IP-cameras, KNX, Helvar, Global Cache, without any problem. With iRidium. And without VPN or other stupid things.


So, my advice: try to find a (temporary) other router and just try it....


Thanks


Theo Derks

Distributor The Netherlands - Belgium - Germany.

Thanks for the reply .As you see on the attached screenshot, I have a physical connection vpn and redirected to port 12004 on the router KNX. So I doubt that it was a problem with the router. What companies are using a router?

Darek.

Today, my phone will automatically update I2 Control to version 2.2.5 126. After running the application got a network connection via knx 3 G without running the vpn client ?? So I concluded that my whole problem with getting connected to the knx network via 3G lay on the side of your application and not my router or ISP.

greetings. Darek.

2.2.5 126?

Strange... Can you send a screenshot of the info-screen with the version number?

We didn't know there is a new version?


Thanks

Theo


    Hi, I also had this problem with baos 772, I was trying to solve the problem, but ineffectually...and at one happy day it was solved, when the customer decided to change the internet provider