0
Answered

Slow to show feedback

Jackie Roos 4 years ago in Products / KNX updated 4 years ago 9

We have a KNX site with approximately 200 group addresses and we are experiencing a lag between sending commands and feedback showing in iRidium.


Do you have any suggestions?

Answered

Hi Jackie


Is it happens for some time after project start or all the time?

Please check, maybe the problem is in the initialization of group addresses.

Try to set "Send Time: 0" in driver settings.

Try to create a project with 2-3 addresses and check for lags

Hi

Problems we are having

- all addresses are getting queried on startup, and each time the iPad add comes to the foregroung

- even with a small project of 3 group addresses there is some lag - not instant. We have connected straight to the IP router to rule out the nextwork

- send time is 0


my questions

- can we control the initial read ?

- does the read happen everytime the ipad project comes to the foreground? Seems to, how do we stop this?

- any idea on the lag? We have connected to this gear this before in training without lag. I am getting the KNX log for you


How do we stop it or tell it to do just some addresses when, eg, we change floors? This installation is waaaaay to big to have this happen everytime the ipad wakes up.



1. You can control it on KNX side. Just turn off the Read tick in the settings of Group Address

2. iRIdium asking for the bus status every time when you start the app. It is not possible to stop this. You can turn off the Init On Start on KNX side or using BAOS protocol.

3. Try to ping the KNX IP Interface (what is the model of interface?), is the Ping stable?
You say you are getting a log, is it ready?


The bug works fine and without lags when you asking for 100-200 addresses. It is not a problem in itself.

Please inform us about ping rate, number of addresses in your project, model of KNX Ip Interface, please send the KNX log



Hi Jackie,

The only thing i can say: we discovered these problems also, when preparing the ISE2015. In that time the software was re-installed on the EVIKA (=Embedded Systems) server.

But now, we have the same problems with the OnBox we have already 7 months in our office: startup is very slow...


Theo

Hi Theo

This topic is in V2.2 forum, so we are looking for reasons in case of 2.2 version without Server

Hi Ekaterina

re: You can control it on KNX side. Just turn off the Read tick in the settings of Group Address


We have done this - but the group addresses without any settings ticked in ETS are getting queried (as they are all importing), up to 3 times each, meaning the initial reads are up to about 6000! This is killing the KNX bus.


I am going on-site with the installer in the morning and will get the log and all the other requested details and everything else I can fine out.


thanks :)

Hi

Solved it. There was daylight harvesting that was still in the process of being setup and tuned - turning this off dramatically reduced the amount of traffic on the bus and iRidium commands and feedback were in nano-seconds - how we expect it :)


We will also reduced all feedback variables as much a possible when we are ready to go live (next week!).


cheers