0
Answered

Нет записи в БД на сервере

Vladimir Volodin 3 months ago in Bugs and problems • updated by Vladimir Ovchinnikov 3 months ago 13

Не сохраняется теги в базу данных, то есть после перезагрузки программы все тэги показывают 0 


модификатор настроил, подписался на тэги, слушаю тэги, все приходит назад и все работает

Under review

Добрый день.

Поле Load On Start должно быть в True для восстановления значений из системной базы данных.

  • Load On Start - восстановить значение переменной из базы данных в случае перезагрузки сервера (в отличие от параметра Persist = Yes будет восстановлено не самое последнее значение, а последнее значение, сохранённое в базе данных).

Пробывал, не помогает, то же самое

Версия студии и версия сервера какие?

а версию сервера я скидывал вроде

На скриншоте отображается версия сервера 1.1.8. Если действительно эта версия используется, то обновите до актуальной (сейчас это 1.3.6).

как обновить?

У вас Raspberry? Версия слишком старая, лучше обновить из консоли. Инструкция тут.

Если у вас UMC, то аналогичная инструкция тут.

Обновил.

Store In DB - формат сохранения переменной в базу данных

если стоит 

  • String UTF8 - сохранять как строку

то сохраняет, если стоит

  • Signed 32bit - сохранять как целое число

не сохраняет, выставлял 

  • Deadband (Value) - минимальное изменение переменной, требующее записи в базу

было 0 поставил 1, не помогло

Load On Start - true исправил проблему 


P.S. 10 минут спустя: сейчас заметил что везде стоит Load On Start - true

Ваш вопрос решён?

Answered

Рады помочь.