+1
Не ошибка

Deadband not working for float-numbers

Martin Lang 3 года назад в Server Solutions обновлен Oksana (expert) 3 года назад 5

i tried to setup the deadband for floatnumbers (temperaturs) to 0,2 or 0,5. but this isn't working.

the character point "." is not accepted in the input field. when using 0,2 for example, the server still stores integer jumps.

Ответ

Ответ
Ожидает ответа пользователя

Hello Martin,

Can you send us your project? We can't repeat.


This is example with Virtual Server Command and Tags.

Float deadband.sirpz

You should set values via Web-interface to Command "Virtual 1" (you should set via point, for example, "1.1"). Web-interface sends value as strings, and function "parseFloat()" changes this string to float


If we test deadband via Modbus TCP driver (for example), we don't need to use "parseFloat()"



Ответ
Ожидает ответа пользователя

Hello Martin,

Can you send us your project? We can't repeat.


This is example with Virtual Server Command and Tags.

Float deadband.sirpz

You should set values via Web-interface to Command "Virtual 1" (you should set via point, for example, "1.1"). Web-interface sends value as strings, and function "parseFloat()" changes this string to float


If we test deadband via Modbus TCP driver (for example), we don't need to use "parseFloat()"



the deadband input field does not accept float numbers. so, setting this to "1" is not an option, because the float numbers are for example 17,326 17,329 17,451 etc... so, how to set the deadband on floatnumbers to "0,1" for example?

the deadband input field does not accept float numbers. so, setting this to "1" is not an option, because the float numbers are for example 17,326 17,329 17,451 etc... so, how to set the deadband on floatnumbers to "0,1" for example?

Hello!


Yes, you can set the deadband for float numbers this way:



Сервис поддержки клиентов работает на платформе UserEcho