XBMC/Kodi JS not connecting

Rafael Pierozzi 7 years ago updated by Aleksandr Romanov (CTO) 7 years ago 17


I'm having some problem when using XBMC JS with KODI devices.

I imported JS modude to a metrohouse GUI but when try to connect it does not connect, just keep trying.

Sometimes it shows a screen asking to try again, sometimes it appears the green aside the kodi name, sometimes red.

Log only shows:

[19-04-2017 17:16:00.833] INFO CORE *** The client started to work ***

[19-04-2017 17:18:20.350] INFO SCRIPT === TestConnect 8080

[19-04-2017 17:18:20.476] INFO SCRIPT === TestConnect 8080

[19-04-2017 17:26:40.407] INFO SCRIPT === TestConnect 8080

[19-04-2017 17:26:45.194] INFO SCRIPT === TestConnect 8080

[19-04-2017 17:26:45.313] INFO SCRIPT === TestConnect 8080

[19-04-2017 17:26:53.075] INFO SCRIPT === TestConnect 8080

Devices tried:

1 - Kodi 16.1 - Windows 7

2 - Kodi 16 - Raspberry pi Openelec

3 - Kodi 17 - Android tablet

4 - Kodi 17 - Macbook pro OSX 10.12.4

If anyone has faced some difficulties like this please share the solution for this issue.



Samples in XBMC.zip worked! Tested on Kodi 17 - Windows 7, iPad 2

use 9090 port

Hi Andrey, thanks for your reply!

I downloaded the xbmc.zip you told but it still not works. Did you make any changes at script ?

I used following data to connect:


host: (my kodi 17 at galaxy note 10.1)

port:9090 (as you told) & ____



thanks again

I did not change anything in the code

Don't change port in Services -> Control in Kodi (default 8080)

9090 port is a built in AJAX service

Just run as example Metro_XBMC_iPhone.irpz, choice "Add" at top menu (

PS: check what "Allow remote control from applications on other systems" is ON

I checked option "Allow remote control from applications on other systems" and it was already ON.

When I input the correct ip address like this ( next time I click Edit, it change ip to and below Port appears 9090. keep not connecting.

Now sometimes log shows the message:

[20-04-2017 08:56:06.426] INFO SCRIPT === TestConnect 9090

[20-04-2017 08:56:09.515] ERROR CUSTOM DeviceXBMC(1): Time of waiting for connection is over!

You did try localhost, when running i3 pro on the some PC? Firewall on local network?

Next steps:

1. Check what 9090 port is correctly opened https://technet.microsoft.com/en-us/sysinternals/tcpview.aspx

2. Make dump of network traffic on localhost https://www.netresec.com/?download=RawCap

I tried localhost:9090, but same result. Now I'm running I3 client from windows PC and tablet... also I'm running Kodi at both devices to try connecting between both.

At pc machine, firewall was completelly disabled. and result from tcpview was:

Kodi.exe 4112 TCP AutomantionNote 9090 AutomantionNote 0 LISTENING

Kodi.exe 4112 TCPV6 [0:0:0:0:0:0:0:0] 9090 [0:0:0:0:0:0:0:0] 0 LISTENING

Great software by the way...

About rawcap, I started recording some packets but I didn't understand how to read the file generated. I tried to open it with notepad.


You may open this file with Wireshark or attach to topic

In the settings nothing else has changed

Hi ,

This is what I could found about packets between Iridium and Kodi. I dont know how to "read" it:

Iridium --> Kodi 0m 0m D\HE4Ev@#tm? ? ?

Kodi --> Iridium D\H0mEl@@~#0fP{"jsonrpc":"2.0","method":"GUI.OnScreensaverDeactivated","params":{"data":{"shuttingdown":false},"sender":"xbmc"}}

Is this information we are looking for ?

please, attach full dump or send it to support@iridiummobile.ru


Here it is the complete file. I captured using wireshark directly. is IP of PC running Emulator instance is IP of tablet running Kodi instance.

Configuration of Kodi was like picture you sent before.


Obviously you are using a template for iPad. In the previous message, I used example Metro_XBMC_iPhone.irpz.
Converting v2 to v3 has a bug: Multistate button replaced by Item button (planned: http://support.iridiummobile.net/topics/11034-pochemu-ne-rabotayut-moduli-posle-importa-v-v3-na-primere-xbmc/).

Add a dozen additional States for "icon_map" and change it type to Multistate button (in the lower right corner on the "XBMC_Audio" Popup) or use the example for the iPhone.

In the example for the iPad, the port 8080 is also specified in the settings, maybe the functionality is not complete.

Use latest version of Iridium.

Thats was the problem. I tried iphone version and it worked pretty well. By the time this is what I need.

I also tried to create multiple states for "icon_map" and change it to multistate button but still not connects.. Do I need to make same procedure for other popus ?

It worked great. I looked for "icon_map" but it has only 2 states (on/off). Isn't there should be other states ?

Have you solved the issue?

Yes, its solved. Thanks