Connecting i3Lite to the Crestron connection

Vladimir Bykov 7 years ago in Products / Other drivers updated by Aleksandr Romanov (CTO) 7 years ago 16


I'm trying to connect i3Lite to the Crestron controller.
But there no connection and crestron error message in the log.
Please, tell what is wrong in my settings.

Image 20541

Image 20542


Under review


Did you try to control the Crestron with an i3 pro project using current parameters? 

No, this is my first attempt to connect Iridium with Crestron.


I will ask co-workers who have worked with Crestron maybe there is something more to setup. I will give to you some advices soon.

Firstly you need to enter in telnet field 41795 value.

Also did you use Crestron SIMPL to program your controller? There you will setup IP ID for a panel. The parameter is needed in i3 lite (you have "20" value for the parameter right now).

Why 41795 for telnet? In Crestron settings 41795 is CTP port, Telnet is 23.

In my SIMPL programm the panel IP-ID = 20. 

Crestron developer said me that you should enter the CTP value to telnet port (more detailed information is here http://wiki2.iridiummobile.net/Crestron). Please, try to change the value and tell us if it helps.

Ok, thanks, I will try tomorroy.

I founded that settings of the Crestron I entered doesn't match the settings from the page "Module Info" (Gear button).
And I didn't see any messages in WireShark.

I entered

Setting from gear button


Any updates?


sorry for the delay.

I will check tomorrow how it works with our crestron.


Vladimir, I suppose that you have different IP-IDs. IP-ID in crestron is in hexadecimal format while in iridium it is decimal. If you've entered IP-ID "20" in crestron, it means that you need to enter IP-ID "32" in iRidium. Make sure, that your panel's IP-ID in crestron matches that value in iRidium. 

I just tested it with our crestron system - it works fine.
Test conditions: iPhone 5S, app from appstore and module version 1.12.0 (the actual one).
I will try it on windows also and tell you about results.

On which device do you have the empty fields after pressing the gear button? And which app version? There should be parameters that you have entered.

Same with windows client (current version from our site) - it works.

Seems like your crestron parameters getting lost when you add the module. If you tell me your test conditions I will try by your way.

Also try to enter IP-ID as "32" on your windows client as Vaclav said before. According to your screen your parameters don't get lost on windows client. 

Vaclav is right. The problem was in IP-ID. I didn't see, that it hex. Now it works fine. Many thanks!

About settings store, I tryed it on Android 6.