Waiting for user's reply

Compatibility for Weinzierl KNX IPBaos774 and IP Interface 730/731

Francesco Zangara 7 years ago in Products / KNX updated 6 years ago 47

iRidium Studio is compatible with IPBoas774, IP Interface 730 and 731?

Studio not find this devices during import.


We did not test these models, but the 774 is the simplified version of the 777, and the 730 should work with the usual KNX driver

Thank you Aleksandr,

but Importer on Studio not recognized this device when import knxproj.

Can you fix it?

Can you send your knxproj file?

iRidium Studio

New project.knxproj

This knxproj contain all ip device of weinzierl (Router 750 and 751, Interface 730 and 731, Baos 771,772,773,774 and 777).

Importer find only Router (i not know if find 750 or 751 or interface), boas 771,772 and 777.

Waiting for user's reply

I checked it out. Unfortunately, we can not add import without checking on real hardware that we do not have. Can you create a project without importing and check that the driver works correctly with these devices? Then we can add these models at least in beta status.

Looking into this KNX project I mayonly say that you have a principal errors when planning your KNX installation

Can you maintain KNX installation via KNX tunneling from ETS?

I do not understand your question, please describe.

Why do really need to know which devices is used, if you only need to know the group addresses and the address of IP interface?

Good day Igor,

the knxproj posted is only for test.

in my case i have only an baos 774 on project, so i need insert manual all object because studio not recognized it when import knxproj.

More, if i have an interface 731 or an router 751, studio not recognized it and not import group address.

I've tried to do the same thing - create a test project with BAOS 774 and two Zennio devices (input and output), create a group address, assign individual inputs and outputs to it, export and import to Studio into KNX Router driver. Be warned: under the term "KNX Router" iRidium assumes any device that can access KNX TP bus from IP environment, either KNX IP Interface (Weinzierl 730 and 731) or KNX IP Router (750 and 751), even all BAOS 77x devices, because they may act as plain KNX IP interface.

So, with 773 an 774 i can use only tunneling side and not the object server side...

in next days i try insert manually the baos, command and feedback into project and connect it with an 774.

Hi Aleksandr,

I try 731 and 774 with manual import.

Both work , 731 with IP Router, 774 with 772 driver.

Now, i have 4 customer that have buy 774 for use with iridium and now they have urgent to this fix!

Under review

hello. We will fix it as soon as possible


we create a beta build with 774 import. I attach it to his post. Test it please. In archive you will find beta exe and new devices.db. You should copy exe file to iridium directory and db file to iridium dir/Database. Wait for you feedback

ST-773 BAOS 774.rar

Waiting for user's reply

Good day Ilya,

I try beta exe and  not it import 774, but:

- 4 float bytes (Dpt14) is import as unsigned 32 bit (Dpt12 4 byte unsigned value) and not as float 32 bit

- 14 bytes character string (Dpt16) is import as 1 bit switch (Dpt1) and not as ASCII String

- Description of datapoint is not import (with 772 are imported)

ETS5 project for test

New project.knxproj

Does you try to import 774?

yes, sorry..i wrong digit a letter...

I try beta exe and  now it import 774, but:

ok, we will fix it soon


we fix strings issue, but issue with datapoint description and issue with 32-signed type is because there is no full link datapoints and group addresses in ets. Check it please ST-773 BAOS 774.rar

Hi Ilya,

Now String is imported, but can you give me more detail for description and 32 type issue?

I try insert an Energy meter (ABB ZS/S1.1) and connect 4bytes-float to it, but still iridium not import it correctly.

Sorry Ilya, I not understand.

If the issue is on ets project, why iridium can load descriptions when import 772 and not when import 774?

More I still not understand what mean "...because there is no full link datapoints and group addresses in ets.". Into knxproj I see all information of datatypes

Hello Ilya.

Yes, i do all on my project (and on test project attached on old message).

I not set all "read" flag because not all group address need answer on read telegram, but importer not work with all object (with or without "read" flag set)

Under review

Ok, we will check it


can't find a problem. can i connect to you PC with ETS on monday and check options?

Good day Ilya.

Yes i can open team viewer for connection.

Contact me on skype.


Send request in skype yesterday

Sorry Ilya, i not receive any notification from skype.

What is your skype name?


stil don't receive your request and, as i understrand, you didn't receive my request. Any way, we remember about you and  today we get knx 773 and 774 devices in our office. Soon we will test all iridium functions with this devices, fix all issues and i will write you about progress.

Thanks for your attention

Dear Ilya, have any news about this issue? I have the same problem..


We find the issue. It is under development now. I will write you when it will be done

Hello Ilya,

Please confirm the compatibilty with ip baos 773 as soon as possible. I,ve to change an ip baos 772 and it,s discontinued.



in latest version you can import baos 774 in your project and works with it, but you can't import datapont description. It will be ready in future. baos 773 is under development now. Soon it will be avaliable. 

Hi Ilya, any progress with IP Baos 773?? You can calculate some term?


Hi, sorry for delay. It was added. Thank you.

Hi Aleksandr,

have you fix the issue with descriptions? now studio import it?


It is in development for ets5. Does you has ets file with descriptions from ets4?

Hi Ilya,

sorry, i'm use ets5.5.4

Hi Ilya,

have news for import descriptions of 774?


not yet. It is in development queue


We have fixed the problem with description in new version 1.2.7


i've just tried with ETS 5.6.4 and iRidium studio 1.2.9 and the description of BAOS774 are not imported..

Hi Matteo,

see this thread https://support.iridiummobile.net/communities/18/topics/15898-read-on-start#comment-98779

Dmitry say that we need use the "Description" field on object and not the "Description" parameter, and we need edit this field manually. If we use automatic filled feature of ETS, the importer not work because ets not save the field on exported project.

But for now, It's not usefull for me.