Напишите здесь описание Вашего форума ...
0
Under review

Is there a script command for turning on DISABLE AUTO LOCK option?

Luka Krcmar 2 years ago in Bugs and problems updated by Vladimir Ovchinnikov 2 years ago 1

I know there is an option for this in the System menu but that option is not reliable. Because of that i would like to add a command in the script so that at every start this option would be turned on.

0
Under review

Error Delay Iridium

dungVN 2 years ago in Bugs and problems updated by Vladimir Ovchinnikov 1 year ago 1

I am working on a project using iridium pro software, knx schneider. There is an error I am making:

Software iridium when running the simulation, when I impact on the object such as: turn on the light, open, close curtains But the system has to wait 2 minutes to execute the command: light on, curtain opening and closing.

But when I directly affected the object value (light on and off, curtains opened and closed) on the central control unit (homelinks), the maximum effect was to change the value immediately (lights on, off, blinds closed, open )

My iridium file is too large to upload here 

Does anyone know this error?file iridium pro

11111.png

File iridium pro

https://drive.google.com/file/d/1OoWfVKE8G1_vrZT2yW8GuDsx8y7rcTv2/view?usp=sharing

0
Fixed

Iridiumserver password with "special" characters

Dennis Piet 2 years ago in Bugs and problems updated by Vladimir Ovchinnikov 9 months ago 1

During intial setup of my first Iridium UMC server I ran into trouble after setting the password.

After that I always got the "wrong password" error when logging in.

With some trial&error I found out that there is a problem with passwords with special characters.

At least passwords with ^ and & give problems.

Please fix this bug, or make sure that the user cannot set password with forbidden characters in the first place.

0
Under review

iRidium server on Raspberry Pi - multiple VLAN control?

Iain Brew 2 years ago in Bugs and problems updated by Vladimir Ovchinnikov 1 year ago 5

I have a Raspberry Pi 4 running iRidium Server. Current setup is:


IP: 192.168.5.10

Subnet: 255.255.0.0

Gateway: 192.168.3.1

VLAN: 1


I have a collection of DANTE devices which I would like to segregate on to VLAN 4. Two of these devices have a single physical ethernet port, but two virtual interfaces with two MAC addresses (Shure MXA910 DANTE microphone). I understand that I could 'tag' the interface of the Raspberry Pi for both VLAN 1 and VLAN 4, but iRidium Server can only send commands on the first interface it sees. 

The DANTE microphone is:

IP: 192.168.22.1

Subnet: 255.255.0.0

Gateway: none

VLAN: 4


Is there a clever way of allowing iRidium Server to control devices across more than one VLAN?

0
Under review

Проблема с GetDevice для панельной части после создания серверного проекта

project 2 years ago in Bugs and problems updated by Vladimir Ovchinnikov 2 years ago 1

Добрый день.

Для панельного проекта написан скрипт:

var d1int = 0;

var d1perm = 0;


//Реле 1 (главный вход)

IR.AddListener(IR.EVENT_ITEM_PRESS, IR.GetItem("MainPage").GetItem("Door1perm"), function ()

{

d1perm = IR.GetItem("MainPage").GetItem("Door1perm").Value;

IR.ClearInterval(d1int);

});

IR.AddListener(IR.EVENT_ITEM_PRESS, IR.GetItem("MainPage").GetItem("Door1"), function ()

{

if(IR.GetItem("MainPage").GetItem("Door1").Value == 0){IR.ClearInterval(d1int);}

if(IR.GetItem("MainPage").GetItem("Door1perm").Value == 0 && d1perm == 1){d1perm = 0;}

d1int = IR.SetTimeout(2000, function()

{

if(d1perm == 0){IR.GetDevice("KNX").Set("Rele1",0);}

});

});

Без серверное части скрипт работал. После создания серверной части и развёртки проекта в виде "панель+сервер" (сервер софтварный, установлен на ПК) строка if(d1perm == 0){IR.GetDevice("KNX").Set("Rele1",0);} стала выдавать ошибку Script exception: TypeError: .... RelayDelay.js:20: Tried to use null as an object.

IR.Log(IR.GetDevice("KNX")) выдаёт null. Команды по нажатию на кнопки (включение/выключение реле на актуаторе) выполняются: реле переключается. Проблема в скрипте или что-то не так настроено в серверной части? Просьба помочь с проблемой (файлы проекта - в приложении).

Project 2 (Panel).irpz
Project 2 (Server).sirpz

0
Under review

Make public

Andreas-P 2 years ago in Bugs and problems updated by Vladimir Ovchinnikov 2 years ago 1

Every time I’m opening the i3 lite app, make public (synchronization of project with server) pop up. 
Sometimes I need to do this 1-3times before it disappears. And when I use the app some hours later, the same problem comes again. 

0
Fixed

iRidium Studio - multiscreen bug

Maciej Walentowski 2 years ago in Bugs and problems updated by Vladimir Ovchinnikov 2 years ago 6

In office I use external screen for my laptop. When use iRidium studio have on main screen, and pages overview, project device panel and device base on second monitor.

When Im out off office and doesn't have external monitor can't find that pages.

0
Under review

MQTT Driver - Client ID

Tero Mäkelä 3 years ago in Bugs and problems updated by Vladimir Ovchinnikov 3 years ago 5

Hi!

Is there any way to create mqtt client id for every iridium client automatically? Now I have to create different iridium clients for every phones, because mqtt disconnects if there is same client id's connected (mqtt client collision).

0
Fixed

deleting server logs on iridium C3 server not working?

JBOY 3 years ago in Bugs and problems updated by Vladimir Ovchinnikov 2 years ago 2

Hi,

I would like to delete the current logs on my UMC C3 iridium server.

When i push the 'delete all logs' button, i see that all references to the log files are removed at that moment.

However, when i load a new project to the server, all old log files are present again.

So: how to remove the logs from the servers through the web interface?


iRidium Server (build 1.3.6.16739, Mar 28 2019 17:38:20) | Web-panel: v1.0.3.20 (Mar 12 2019)

 working with studio V1.3.6.20458

Thanks,

Joachim

0
Under review

Не приходя фидбэки от модуля тёплых полов HDL Buspro MFH06.432

Умед 3 years ago in Bugs and problems updated by Vladimir Ovchinnikov 3 years ago 7

Добрый день. Проблема заключается в том, что от модуля тёплых полов не приходят фидбеки об уставки, выбранном режиме и кнопки включения тёплого пола. Хотя все эти данные подгружаются при старте проекта.